How to solve - "Node Sass version 8.0.0 is incompatible with ^4.0.0 || ^5.0.0 || ^6.0.0"


So after cloning some NodeJS repo, or even your own repo, and when trying to build you get the error:

"Node Sass version 8.0.0 is incompatible with ^4.0.0 || ^5.0.0 || ^6.0.0"

This is annoying I know, I spent a few hours yesterday trying to fix that even with my own repo. There were some suggestion to just find a compatible version of Node and NVM but sometimes we cannot use the latest version of NodeJS. So here is your simplest solution:

If you are using yarn

1. Remove "node-sass"

yarn remove node-sass

2. Instead "sass" instead of "node-sass"

yarn add -D sass

For those who you are using npm

1. Remove "node-sass"

npm uninstall node-sass

2. Instead "sass" instead of "node-sass"

npm i -D sass

Try to run "yarn" again, it should build without any issues. Please let others know in the comment section below if this solution works for you, so they can avoid looking further! Thanks.


If you have any questions, please feel free to comment down here or reach me on my facebook page. I will get back to you as soon as I can! Thank you.


Contact Form